Проверка пропускной способности канала на Mikrotik

Скрипт для Mikrotik RouterOS, тестирующий пропускную способность канала и записывающий результат в файл. Перед запуском создать файл isp-quality.txt и указать IP своего btest сервера в ipbandswtestserverhttps://github.com/devi1/RouterOS-scripts/tree/master/bandwidth%20test:local txAvg 0:local rxAvg 0:local ipbandswtestserver your.btest.server.ip:local btuser btest:local btpwd btest:local ts [/system clock get time]:local ContentsFile [/file get isp-quality.txt contents]:local ds [/system clock get date]:set ts ([:pick $ts 0 2].[:pick $ts 3 5].[:pick $ts 6 8]):set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])tool bandwidth-test protocol=tcp direction=transmit address=$ipbandswtestserver duration=5s do={:set txAvg ($“tx-total-average” / 1048576 );}tool bandwidth-test protocol=tcp direction=receive address=$ipbandswtestserver duration=5s do={:set rxAvg ($“rx-total-average” / 1048576 );}/file set isp-quality.

Мikrotik RouterOS Configuration Management с помощью скриптов и какой-то там матери

Жизненный цикл сети часто переживает закономерный рост. В это время начинают появляться десятки и сотни устройств, конфигурация которых однотипна. Например, это могут быть маршрутизаторы в филиалах, которые имеют одинаковые настройки и отличаются только IP адресами, паролями на VPN и Wi-Fi. Внесение даже незначительных изменений на десяток устройств потребует значительного времени и концентрации. Для управления сотнями и тысячами устройств весь цивилизованный мир уже давно использует специальные системы менеджмента конфигураций: Ansible, Chef, Puppet.

Yet another RouterOS script

Скрипт ищет интерфейс sstp клиента, имя которого содержит в себе строку video, копирует имя интерфейса, имя пользователя и пароль для подключения, а так же адрес vpn сервера. Удаляет упоминание об этом интерфейсе в настройках OSPF (т.к. после удаления появится интерфейс unknown, а без удаления интерфейса новый не создастся - имена одинаковые), создает нешифрованное соединение pptp с аналогичными настройками и вписывает его в параметры OSPF.#!Ищет sstp-интерфейс с именем, содержащим video#! копирует его настройки, убирает номер порта и#!

Самый полный мануал по резервированию интернета на Mikrotik RouterOS

В сети много мануалов по фэйловеру на RouterOS и подобрать нужный под конкретные цели иногда проблематично. В ходе своих экспериментов я выяснил, что наиболее универсальным является этот способ. Но у меня возникло несколько вопросов, ответы на которые я пока не нашел. /ip route add dst-address=Host1 gateway=GW1 scope=10 add dst-address=Host2 gateway=GW2 scope=10 /ip route add distance=1 gateway=Host1 routing-mark=ISP1 check-gateway=ping add distance=2 gateway=Host2 routing-mark=ISP1 check-gateway=ping /ip route add distance=1 gateway=Host2 routing-mark=ISP2 check-gateway=ping add distance=2 gateway=Host1 routing-mark=ISP2 check-gateway=ping Я делаю немного по-другому: первые две строки точно такие же, а дальше:

Скрипт для проверки наличия USB-модема на RouterOS

Понадобился скрипт, определяющий наличие USB-модема, подключенного к Mikrotik. Присылает на почту название модема и его серийник. Хорошо бы допилить скрипт до отправки уровня сигнала и количества денег на счете, но мои модемы не дают доступа к своему меню - надо шить.:log info “Starting Modem Info Script…”;:local sysname [/system identity get name];:local sysver [/system package get system version];:local mname [/system resource usb get 1 value-name=name];:local mnumber [/system resource usb get 1 value-name=serial-number];:local smtpserv [:resolve “smtp.